summaryrefslogtreecommitdiff
path: root/src/lib/evas/canvas/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/evas/canvas/meson.build')
-rw-r--r--src/lib/evas/canvas/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/lib/evas/canvas/meson.build b/src/lib/evas/canvas/meson.build
index db23590ba3..09320e690d 100644
--- a/src/lib/evas/canvas/meson.build
+++ b/src/lib/evas/canvas/meson.build
@@ -62,6 +62,7 @@ foreach eo_file : priv_eo_files
'-o', 'h:' + join_paths(meson.current_build_dir(), eo_file + '.h'),
'-o', 'c:' + join_paths(meson.current_build_dir(), eo_file + '.c'),
'-o', 'd:' + join_paths(meson.current_build_dir(), eo_file + '.d'),
+ '-e', 'EVAS_API',
'-gchd', '@INPUT@'])
endforeach
@@ -80,6 +81,7 @@ foreach eo_file : pub_eo_files
'-o', 'h:' + join_paths(meson.current_build_dir(), eo_file + '.h'),
'-o', 'c:' + join_paths(meson.current_build_dir(), eo_file + '.c'),
'-o', 'd:' + join_paths(meson.current_build_dir(), eo_file + '.d'),
+ '-e', 'EVAS_API',
'-gchd', '@INPUT@'])
endforeach
@@ -101,6 +103,7 @@ foreach eo_file : pub_eo_types_files
command : eolian_gen + [ '-I', meson.current_source_dir(), eolian_include_directories,
'-o', 'h:' + join_paths(meson.current_build_dir(), eo_file + '.h'),
'-o', 'd:' + join_paths(meson.current_build_dir(), eo_file + '.d'),
+ '-e', 'EVAS_API',
'-ghd', '@INPUT@'])
endforeach