summaryrefslogtreecommitdiff
path: root/src/modules/elementary/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/elementary/meson.build')
-rw-r--r--src/modules/elementary/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/modules/elementary/meson.build b/src/modules/elementary/meson.build
new file mode 100644
index 0000000000..ed77fe240e
--- /dev/null
+++ b/src/modules/elementary/meson.build
@@ -0,0 +1,14 @@
+mods = [
+ 'access_output',
+ 'clock_input_ctxpopup',
+ 'prefs',
+ 'test_entry',
+ 'test_map',
+ join_paths('web', 'none')
+]
+
+foreach mod : mods
+ mod_install_dir = join_paths(dir_lib, 'elementary', 'modules', mod, version_name)
+ subdir(mod)
+ module_files += join_paths(mod_install_dir, 'lib'+mod+'.'+sys_mod_extension)
+endforeach