summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Efl.Ui.Image.Zoomable: implement Ui.Image.icon propertydevs/ami/zoom_iconAmitesh Singh2017-06-027-3/+420
| | | | @feature
* ecore_imf: Add commit content event callbackJihoon Kim2017-06-021-1/+16
| | | | | | | COMMIT_CONTENT is called when the input method commits content such as an image. Change-Id: Idf238dc9b27811999b1ee733eeba2318d57e54f1 Signed-off-by: Jihoon Kim <jihoon48.kim@samsung.com>
* elput: Fix logind session object pathDerek Foreman2017-05-311-4/+49
| | | | | | | We're supposed to query the path for a session id instead of just making up the string ourselves. Fixes all input devices being dead after a vc switch for some users.
* Efl.Ui.Image.Zoomable: inherit from Efl.Ui.ImageAmitesh Singh2017-05-311-4/+3
|
* elm_image: Fix previous image visible issuejiin.moon2017-05-311-0/+3
| | | | | | | | | | | | | | Summary: Previous image still visible when elm_image_file_set has wrong file path. Test Plan: self Reviewers: jpeg, jypark, singh.amitesh Reviewed By: singh.amitesh Subscribers: singh.amitesh, minkyu, cedric Differential Revision: https://phab.enlightenment.org/D4888
* edje: Move some functions to Efl.Ui.Base (EO)Jean-Philippe Andre2017-05-318-72/+192
| | | | | | | | | | | | | | | | | This introduces the new interface Efl.Ui.Base, intended to share some APIs between Edje and Elm: - mirrored (rtl) - language - scale base_scale remains in Edje.Object for now. I don't think it applies to generic widgets. The new interface uses eo prefix "efl_ui". It could be renamed as Efl.Ui (no Base), or anything else. As always, I'm open to propositions! Ref T5315
* interfaces: Remove display_mode from EO size hintsJean-Philippe Andre2017-05-318-66/+34
| | | | | | | | | This size hint is only used by naviframe, which is not part of our EO widgets. I also believe it might be an even more confusing hint than the others. I kept the typedef as is in Evas_Legacy.h in case an app is written using EFL_GFX_ instead of EVAS_...
* edje: Reshuffle a bit edje_object.eoJean-Philippe Andre2017-05-316-171/+165
| | | | | | | | | | | | This changes a few method names: - freeze -> calc_freeze - thaw -> calc_thaw - update_hints -> calc_update_hints Otherwise this is mostly about reshuffling the EO file itself and changing documentation. Ref T5315
* edje: Rename "data" to "group_data" for EOJean-Philippe Andre2017-05-312-26/+21
| | | | | | | | Still not happy with the name. I'm trying to avoid a name clash between other "data" elements in the object. This is the EDC group "data item". Ref T5315
* drm: Fix build warning (invalid enum type)Jean-Philippe Andre2017-05-311-2/+2
|
* edje: Revert build fix and make "internal" eo publicJean-Philippe Andre2017-05-311-9/+8
| | | | | | | | | | | | | | Those classes are simply badly named, and I've come to realize since that part class definitions are not internal, but instead they are part of the public API. They are required for documentation, casting, etc... I will rename them to "part" instead of "internal" later. Since the headers are included in Edje_Eo.h not installing them broke the build of any external app. Sorry for the mess! This reverts 665856027d85802a29ede6f005674a8294df60fe Ref T5306
* edje: Remove external param_set from EOJean-Philippe Andre2017-05-314-245/+19
| | | | | | | | | | As Dave pointed out, those are meant for internal use by Edje and the plugins implementation, rather than for apps. This removes ugly and complex code. Makes me happy :) Note that I've kept the composition for now. We can remove it as efl_content_get() must work on the part handle anyway. But it can be used as a quick solution.
* test: Cleanup timer when window is closedJean-Philippe Andre2017-05-311-1/+15
| | | | This avoids confusing ERR messages in efl_part().
* edje: Move part drag APIs to efl_partJean-Philippe Andre2017-05-3117-240/+621
| | | | | | | | | This moves all part_drag APIs to legacy and implements them for EO using efl_part(). All parts now support these APIs, even if they are not draggable. Making this more fine grained would probably be much extra work for little gain. This creates a new interface Efl.Ui.Drag.
* edje: Improve reference doc for part drag APIsJean-Philippe Andre2017-05-311-92/+106
|
* popup: remove previous object when setting new contentJinYong Park2017-05-311-0/+2
| | | | | | | | | | | | | | | | | | | Summary: Other widgets remove previous object when setting new content, but popup does nothing for the part whose name is "default". content_unset can be used to keep previous content object, so content_set (especially with NULL) should be able to delete previous content object for uniformity of the entire widgets. @fix Reviewers: jpeg, singh.amitesh, cedric, raster, conr2d Reviewed By: conr2d Subscribers: minkyu, herb Differential Revision: https://phab.enlightenment.org/D4885
* edje: temporary build fix.Cedric BAIL2017-05-301-3/+5
| | | | | Currently Edje_Eo.h does use all the internal eo file for part. This should be fixed soon, but in the mean time we need a usable tree.
* ecore-drm2: Don't free output plane states if not using atomicChris Michael2017-05-301-6/+6
| | | | | | | | | If atomic support is not enabled (kernel or env var), then we will not be filling output plane_states, so no need to free them (if non-atomic). @fix Signed-off-by: Chris Michael <cp.michael@samsung.com>
* ecore-drm2: Minor formatting fixChris Michael2017-05-301-4/+7
| | | | | | NB: No functional changes Signed-off-by: Chris Michael <cp.michael@samsung.com>
* eolian: add new unit APIDaniel Kolesa2017-05-3024-419/+563
|\ | | | | | | | | | | | | | | | | | | | | | | | | The idea of units (as in translation units) is to encapsulate a single parser pass into a structure to prevent leakage of data from other passes (therefore catching error cases that couldn't be caught before). The internals of the unit system are currently not implemented, this batch merely switches all the relevant APIs to use units as well as updates various things that use those APIs; implementation will come afterwards. @feature
| * eolian: silence a unused warning temporarilyDaniel Kolesa2017-05-301-1/+1
| |
| * docgen: stub out units so the generator works againDaniel Kolesa2017-05-301-25/+48
| |
| * eolian: use unit in typedecl c_type_getDaniel Kolesa2017-05-305-9/+9
| |
| * eolian: pass unit in internal type serializationDaniel Kolesa2017-05-303-7/+9
| |
| * eolian: doc token ref resolver now takes unitDaniel Kolesa2017-05-305-19/+18
| |
| * eolian: type_class_get takes unitDaniel Kolesa2017-05-304-8/+9
| |
| * eolian: expr eval APIs now take unitsDaniel Kolesa2017-05-308-46/+52
| |
| * eolian: more expr system unit updatesDaniel Kolesa2017-05-303-15/+17
| |
| * eolian: pass unit around in expr evalDaniel Kolesa2017-05-301-29/+29
| |
| * eolian: update lua bindings with new unit apisDaniel Kolesa2017-05-301-18/+18
| |
| * eolian: use unit in all getters for typedeclsDaniel Kolesa2017-05-302-6/+9
| |
| * eolian: use units in by_file getters for typedeclsDaniel Kolesa2017-05-303-7/+13
| |
| * eolian: pass unit to enum get by nameDaniel Kolesa2017-05-307-13/+17
| |
| * eolian: pass unit to struct get by nameDaniel Kolesa2017-05-306-19/+22
| |
| * eolian: pass unit to alias get by nameDaniel Kolesa2017-05-305-17/+20
| |
| * eolian: return real nil on parse failureDaniel Kolesa2017-05-301-1/+5
| |
| * elua: update for unit api usageDaniel Kolesa2017-05-301-3/+7
| |
| * eolian: update tests according to unit APIDaniel Kolesa2017-05-301-44/+60
| |
| * eolian: pass unit to all_classes_getDaniel Kolesa2017-05-304-6/+8
| |
| * eolian: pass unit to class get_by_name/fileDaniel Kolesa2017-05-3012-77/+92
| |
| * eolian: make all variable lookups take unitDaniel Kolesa2017-05-303-10/+10
| |
| * eolian: make by-file variable lookups take unitDaniel Kolesa2017-05-303-10/+14
| |
| * eolian: make by-name variable lookups take unitDaniel Kolesa2017-05-305-21/+29
| |
| * eolian gen: pass the unit aroundDaniel Kolesa2017-05-307-31/+40
| |
| * eolian: make eolian_file_parse return unitDaniel Kolesa2017-05-304-9/+12
| |
| * eolian: units will contain multiple filesDaniel Kolesa2017-05-301-2/+1
| |
| * eolian: initial structure for unitsDaniel Kolesa2017-05-303-0/+28
|/ | | | | | Units are Eolian files (eo/eot). Each unit contains information about its class, dependencies, variables and types. This allows for saner checking to be done.
* ecore-drm2: Don't fill device atomic state if atomic is disabledChris Michael2017-05-301-4/+8
| | | | | | | | | If atomic support is disabled (via kernel or env var), then we do not need to fill device atomic state as it will not be used anyway. @fix Signed-off-by: Chris Michael <cp.michael@samsung.com>
* ecore-drm2: Don't fill output atomic states if not using atomicChris Michael2017-05-301-8/+14
| | | | | | | | | If atomic support is not enabled (kernel or env var), then we should not be filling in output atomic state @fix Signed-off-by: Chris Michael <cp.michael@samsung.com>
* ecore-drm2: Remove useless returnChris Michael2017-05-301-1/+0
| | | | | | | This 'return' statement here is just useless as the code can fall through and the function will return 0 anwyay. Signed-off-by: Chris Michael <cp.michael@samsung.com>