summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Bail <cedric.bail@free.fr>2013-03-18 00:07:34 +0900
committerCedric Bail <cedric.bail@free.fr>2013-03-18 00:07:34 +0900
commit2f6fcf42287f177587373c0704ee6d5679fca261 (patch)
tree86e1c63d48634e91653c3af20fee6841d308a6d9 /configure.ac
parent1a472d475eaa557b66675298be90899e13d267ab (diff)
downloadenlightenment-2f6fcf42287f177587373c0704ee6d5679fca261.tar.gz
e: add automatic desktop lock/unlock when a bluetooth device disapear.
This use a custom implementation of l2ping to ping known device and do proper action when they go away. I don't recommend to use the auto unlonck, but it is there if someone need it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 82c0a5bef6..b3dbcec655 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,9 +197,13 @@ CPPFLAGS="${PCPPFLAGS}"
AC_SUBST(cf_cflags)
AC_SUBST(cf_libs)
-AC_CHECK_HEADERS([bluetooth/bluetooth.h],
- [have_bluetooth_h="yes"],
- [have_bluetooth_h="no"])
+PKG_CHECK_MODULES([BLUEZ], [bluez],
+ [have_bluetooth="yes"],
+ [have_bluetooth="no"])
+AM_CONDITIONAL([HAVE_BLUETOOTH], [test "x${have_bluetooth}"])
+if test "x${have_bluetooth}"; then
+ AC_DEFINE_UNQUOTED([HAVE_BLUETOOTH], [1], [Bluetooth is there])
+fi
execinfo_libs=""
AC_CHECK_HEADERS([execinfo.h], [have_execinfo="yes"], [have_execinfo="no"])
@@ -487,6 +491,7 @@ PKG_CHECK_MODULES(E_FM_OPEN, [
PKG_CHECK_MODULES(E_SYS, [
eina >= ${efl_version}
+ ecore >= ${efl_version}
])
PKG_CHECK_MODULES(E_INIT, [