summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Michael <cp.michael@samsung.com>2013-04-17 06:29:12 +0100
committerChris Michael <cp.michael@samsung.com>2013-04-17 06:29:12 +0100
commit7d82951b4aa2c8015bfadfede46330d7ab213952 (patch)
tree63a0be5c9234f3f0bb3bacf116f5f5b22f1d55e8 /configure.ac
parentefa7f678931295cddc65189d1b55dca778cc2c32 (diff)
downloadenlightenment-7d82951b4aa2c8015bfadfede46330d7ab213952.tar.gz
Fix breakage caused by 3e690812b07bccce4cd2909d1d3e6e145707a8c5
Allow building of wl_desktop_shell module again. This works for both cases (wayland and not wayland) now. Signed-off-by: Chris Michael <cp.michael@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 26f89eccea..11e0b9ed08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,11 +867,12 @@ AM_CONDITIONAL([HAVE_WAYLAND_EGL], [test "x${have_wayland_egl}" = "xyes"])
define([CHECK_MODULE_WL_DESKTOP_SHELL],
[
if test "x${have_wayland_clients}" = "xyes"; then
- PKG_CHECK_EXISTS([ ecore >= $efl_version eina >= $efl_version ], [WL_DESKTOP_SHELL=true], [WL_DESKTOP_SHELL=false])
+ AC_E_CHECK_PKG(WL_DESKTOP_SHELL, [ ecore >= $efl_version eina >= $efl_version ], [WL_DESKTOP_SHELL=true], [WL_DESKTOP_SHELL=false])
else
WL_DESKTOP_SHELL=false
fi
])
+AM_CONDITIONAL([HAVE_WL_DESKTOP_SHELL], [test "x${WL_DESKTOP_SHELL}" = "xtrue"])
AC_E_OPTIONAL_MODULE([ibar], true)
AC_E_OPTIONAL_MODULE([clock], true)