summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMike Blumenkrantz <zmike@osg.samsung.com>2017-09-29 13:45:26 -0400
committerMike Blumenkrantz <zmike@osg.samsung.com>2017-09-29 13:45:21 -0400
commitd1cac14aee5b197eeea9d30e46c8dae0fd2c1927 (patch)
treed6e996b0694964b234c7bfd6e4cc3b1e3ed370cc /meson.build
parent839ae73ddb4d242806cb86701755c31be512f467 (diff)
downloadenlightenment-d1cac14aee5b197eeea9d30e46c8dae0fd2c1927.tar.gz
unset release mode
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 14 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 04c06a8eed..a8e6c048a3 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
##### project
project('enlightenment', 'c',
- version : '0.22.0-beta',
+ version : '0.21.99',
license : 'BSD 2 clause',
default_options: [ 'c_std=gnu99', 'warning_level=2' ],
meson_version : '>= 0.40.0')
@@ -16,22 +16,22 @@ if clean_check.returncode() == 0
error('Meson build requires a clean source tree')
endif
-#e_version = ver.split('.')
-#git_version = '0'
-#git = find_program('git')
-#if git.found() == true
- #git_cmd = run_command(git.path(), 'rev-list', '--count', 'HEAD')
- #if git_cmd.returncode() == 0
- #git_version = git_cmd.stdout().strip()
- #endif
-#endif
+e_version = ver.split('.')
+git_version = '0'
+git = find_program('git')
+if git.found() == true
+ git_cmd = run_command(git.path(), 'rev-list', '--count', 'HEAD')
+ if git_cmd.returncode() == 0
+ git_version = git_cmd.stdout().strip()
+ endif
+endif
-#e_version_rev = '.'.join([ver, git_version])
-e_version_rev = ver
+e_version_rev = '.'.join([ver, git_version])
+#e_version_rev = e_version
efl_version = '>= 1.20.4'
-release = '0.22-beta'
+release = 'ver-0.22'
#for releases
#release = '@0@.@1@.@2@'.format(e_version[0], e_version[1], e_version[2])
@@ -82,7 +82,7 @@ config_h.set('_ALL_SOURCE' , '1')
config_h.set('_POSIX_PTHREAD_SEMANTICS', '1')
config_h.set('_TANDEM_SOURCE' , '1')
config_h.set('__EXTENSIONS__' , '1')
-config_h.set('E_RELEASE_BUILD' , '1')
+#config_h.set('E_RELEASE_BUILD' , '1')
if get_option('nls') == true
subdir('po')