summaryrefslogtreecommitdiff
path: root/src/modules/conf_shelves/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/conf_shelves/meson.build')
-rw-r--r--src/modules/conf_shelves/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/modules/conf_shelves/meson.build b/src/modules/conf_shelves/meson.build
new file mode 100644
index 0000000000..387aeec86f
--- /dev/null
+++ b/src/modules/conf_shelves/meson.build
@@ -0,0 +1,31 @@
+conf_shelves_dist = [
+ 'e-module-conf_shelves.edj',
+ 'module.desktop',
+]
+
+conf_shelves_src = [
+ 'e_int_config_shelf.c',
+ 'e_mod_main.c',
+ 'e_int_config_shelf.h',
+ 'e_mod_main.h',
+]
+
+conf_shelves_dir = join_paths(dir_module_e, 'conf_shelves', module_arch)
+if get_option('conf-shelves') == true
+ config_h.set('USE_MODULE_CONF_SHELVES', '1')
+
+ install_data(conf_shelves_dist,
+ install_dir: join_paths(dir_module_e, 'conf_shelves')
+ )
+
+ module_files += join_paths(conf_shelves_dir, 'conf_shelves.so')
+ shared_module('conf_shelves',
+ conf_shelves_src,
+ include_directories: include_directories(module_includes),
+ name_prefix: '',
+ dependencies: module_deps,
+ install_dir: conf_shelves_dir,
+ install: true
+ )
+endif
+