summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Jennings <mej@lbl.gov>2013-03-05 12:58:01 -0800
committerMichael Jennings <mej@lbl.gov>2013-03-05 12:58:01 -0800
commit9d0be7b7d259415771e22565fe29bafe52df3606 (patch)
tree0c8a29bffa425b0fbd8264bc91074740f8a45f1a /configure.ac
parent0527261a853b728c76b22cd11f6cbaf80d2a486f (diff)
downloadlibast-9d0be7b7d259415771e22565fe29bafe52df3606.tar.gz
Updated the autotools stuff some. Bumped version to 0.8.
Reformatted some macros in libast.h. Fixed the sprintf() methods of the str, ustr, and mbuff classes. Added check for compiler support of compound statement expressions. Fixed a spec file bug.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 5 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 633504e..8e6bfb1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,54 +1,16 @@
-dnl# $Id$
-
-test "x$LIBTOOLIZE" = "x" && LIBTOOLIZE=libtoolize
-test "x$ACLOCAL" = "x" && ACLOCAL=aclocal
-test "x$AUTOCONF" = "x" && AUTOCONF=autoconf
-test "x$AUTOHEADER" = "x" && AUTOHEADER=autoheader
-test "x$AUTOMAKE" = "x" && AUTOMAKE=automake
-
-AC_SUBST(LIBTOOLIZE)
-AC_SUBST(ACLOCAL)
-AC_SUBST(AUTOCONF)
-AC_SUBST(AUTOHEADER)
-AC_SUBST(AUTOMAKE)
-
-SAVE_LIBTOOLIZE="$LIBTOOLIZE"
-SAVE_ACLOCAL="$ACLOCAL"
-SAVE_AUTOCONF="$AUTOCONF"
-SAVE_AUTOHEADER="$AUTOHEADER"
-SAVE_AUTOMAKE="$AUTOMAKE"
+# $Id$
AC_INIT(configure.ac)
-AM_INIT_AUTOMAKE(libast, 0.7.1)
+AM_INIT_AUTOMAKE([libast], [0.8])
AC_DEFINE_UNQUOTED(LIBAST_VERSION, "$VERSION", [Version])
-AC_CONFIG_HEADERS(config.h include/libast/sysdefs.h)
-
-LIBTOOLIZE="${SAVE_LIBTOOLIZE:-libtoolize}"
-ACLOCAL="${SAVE_ACLOCAL:-aclocal}"
-AUTOCONF="${SAVE_AUTOCONF:-autoconf}"
-AUTOHEADER="${SAVE_AUTOHEADER:-autoheader}"
-AUTOMAKE="${SAVE_AUTOMAKE:-automake}"
-
-AC_MSG_CHECKING(for preferred libtoolize)
-AC_MSG_RESULT($LIBTOOLIZE)
-AC_MSG_CHECKING(for preferred aclocal)
-AC_MSG_RESULT($ACLOCAL)
-AC_MSG_CHECKING(for preferred autoconf)
-AC_MSG_RESULT($AUTOCONF)
-AC_MSG_CHECKING(for preferred autoheader)
-AC_MSG_RESULT($AUTOHEADER)
-AC_MSG_CHECKING(for preferred automake)
-AC_MSG_RESULT($AUTOMAKE)
+AC_CONFIG_HEADERS([config.h include/libast/sysdefs.h])
+AC_CONFIG_MACRO_DIR([.])
dnl# Set some basic variables
AUTHORS="Michael Jennings (mej@eterm.org)"
AC_SUBST(AUTHORS)
AC_DEFINE_UNQUOTED(AUTHORS, "$AUTHORS", [Authors])
-AC_CANONICAL_BUILD()
-AC_CANONICAL_HOST()
-AC_CANONICAL_TARGET()
-
AC_PROG_CC
AC_PROG_CPP
@@ -58,6 +20,7 @@ AST_VAR_CHECKS()
AST_HEADER_CHECKS()
AST_TYPE_CHECKS()
AST_FUNC_CHECKS()
+AST_COMPILER_CHECKS()
AC_PROG_LIBTOOL()