summaryrefslogtreecommitdiff
path: root/erts/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'erts/configure.ac')
-rw-r--r--erts/configure.ac59
1 files changed, 16 insertions, 43 deletions
diff --git a/erts/configure.ac b/erts/configure.ac
index 307be5042d..540cc4b3cb 100644
--- a/erts/configure.ac
+++ b/erts/configure.ac
@@ -1356,6 +1356,19 @@ if test "x$enable_esock_rcvsndtimeo" = "xyes"; then
fi
+dnl *** ESOCK_USE_EXTERNDED_ERROR_INFO ***
+
+AC_ARG_ENABLE(esock_extended_error_info,
+AS_HELP_STRING([--enable-esock-extended-error-info], [enable use of extended error info])
+AS_HELP_STRING([--disable-esock-extended-error-info], [disable use of extended error info (default)]))
+
+dnl Temporary! Currently we require eei to be *explicitly*
+dnl disabled (for debug reasons).
+if test "x$enable_esock_extended_error_info" != "xno"; then
+ AC_DEFINE(ESOCK_USE_EXTENDED_ERROR_INFO, [1], [Use extended error info])
+fi
+
+
dnl *** ESOCK_COUNTER_SIZE ***
AC_ARG_WITH(esock-counter-size,
@@ -1710,9 +1723,9 @@ AS_IF([test x"$ac_cv_lib_dlpi_dlpi_open" = x"no"],
try_dlpi_lib=$erl_xcomp_sysroot/lib
if test x"$ac_cv_sizeof_void_p" = x"8"; then
if test -d $erl_xcomp_sysroot/lib64; then
- try_dlpi_lib= $erl_xcomp_sysroot/lib64
+ try_dlpi_lib=$erl_xcomp_sysroot/lib64
elif test -d $erl_xcomp_sysroot/lib/64; then
- try_dlpi_lib= $erl_xcomp_sysroot/lib/64
+ try_dlpi_lib=$erl_xcomp_sysroot/lib/64
fi
fi
if test ! -f "$try_dlpi_lib/libdlpi.so" && \
@@ -2168,7 +2181,7 @@ AC_CHECK_FUNCS([getipnodebyname getipnodebyaddr gethostbyname2])
AC_CHECK_FUNCS([ieee_handler fpsetmask finite isnan isinf res_gethostbyname dlopen \
dlvsym pread pwrite memmove strerror strerror_r strncasecmp \
gethrtime localtime_r gmtime_r mprotect madvise posix_madvise \
- mmap mremap memcpy mallopt sbrk _sbrk __sbrk brk _brk __brk \
+ mmap mremap memcpy memrchr mallopt sbrk _sbrk __sbrk brk _brk __brk \
flockfile fstat strlcpy strlcat setsid posix2time time2posix \
setlocale nl_langinfo poll mlockall ppoll vsyslog])
@@ -3487,26 +3500,6 @@ AC_DEFINE_UNQUOTED(ERTS_EMU_CMDLINE_FLAGS,
AC_SUBST(STATIC_CFLAGS)
-dnl ----------------------------------------------------------------------
-dnl Directories needed for the build
-dnl ----------------------------------------------------------------------
-
-erts=${erl_top}/erts
-
-erts_dirs="
- $erts/obj $erts/obj.debug
-
- $erts/obj/$host
- $erts/obj.debug/$host
-
-"
-for d in ${erl_top}/bin ${erl_top}/bin/$host $erts_dirs ;
-do
- if test ! -d $d; then
- mkdir -p 1>/dev/null 2>&1 $d
- fi
-done
-
dnl ---------------------------------------------------------------------
dnl Autoheader macro for adding code at top and bottom of config.h.in
dnl ---------------------------------------------------------------------
@@ -3580,26 +3573,6 @@ if test "x$GCC" = xyes; then
fi
dnl ----------------------------------------------------------------------
-dnl Enable -fsanitize= flags.
-dnl ----------------------------------------------------------------------
-
-m4_define(DEFAULT_SANITIZERS, [address,undefined])
-AC_ARG_ENABLE(
- sanitizers,
- AS_HELP_STRING(
- [--enable-sanitizers@<:@=comma-separated list of sanitizers@:>@],
- [Default=DEFAULT_SANITIZERS]),
-[
-case "$enableval" in
- no) sanitizers= ;;
- yes) sanitizers="-fsanitize=DEFAULT_SANITIZERS" ;;
- *) sanitizers="-fsanitize=$enableval" ;;
-esac
-CFLAGS="$CFLAGS $sanitizers"
-LDFLAGS="$LDFLAGS $sanitizers"
-])
-
-dnl ----------------------------------------------------------------------
dnl Enable build determinism flag
dnl ----------------------------------------------------------------------