summaryrefslogtreecommitdiff
path: root/erts/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index d8ad6ff552..d7828ca14f 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1475,6 +1475,42 @@ AS_IF([test "x$enable_esock_socket_registry" = "xno"], [
[Use socket registry by default])])
+AC_CHECK_MEMBERS([struct ifreq.ifr_map],
+ [AC_DEFINE(ESOCK_USE_IFMAP, [], [Interface map supported])],
+ [],
+ [#ifdef __WIN32__
+ #else
+ #include <net/if.h>
+ #endif
+ ])
+
+AC_CHECK_MEMBERS([struct ifreq.ifr_hwaddr],
+ [AC_DEFINE(ESOCK_USE_HWADDR, [], [Interface hwaddr supported])],
+ [],
+ [#ifdef __WIN32__
+ #else
+ #include <net/if.h>
+ #endif
+ ])
+
+AC_CHECK_MEMBERS([struct ifreq.ifr_ifindex],
+ [AC_DEFINE(ESOCK_USE_IFINDEX, [], [Interface ifindex supported])],
+ [],
+ [#ifdef __WIN32__
+ #else
+ #include <net/if.h>
+ #endif
+ ])
+
+AC_CHECK_MEMBERS([struct ifreq.ifr_index],
+ [AC_DEFINE(ESOCK_USE_INDEX, [], [Interface index supported])],
+ [],
+ [#ifdef __WIN32__
+ #else
+ #include <net/if.h>
+ #endif
+ ])
+
dnl
dnl This test kindly borrowed from Tcl