summaryrefslogtreecommitdiff
path: root/lib/odbc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/odbc/configure.ac')
-rw-r--r--lib/odbc/configure.ac22
1 files changed, 1 insertions, 21 deletions
diff --git a/lib/odbc/configure.ac b/lib/odbc/configure.ac
index dfc3a6ec04..febdd044a5 100644
--- a/lib/odbc/configure.ac
+++ b/lib/odbc/configure.ac
@@ -1,7 +1,7 @@
dnl
dnl %CopyrightBegin%
dnl
-dnl Copyright Ericsson AB 2005-2021. All Rights Reserved.
+dnl Copyright Ericsson AB 2005-2023. All Rights Reserved.
dnl
dnl Licensed under the Apache License, Version 2.0 (the "License");
dnl you may not use this file except in compliance with the License.
@@ -256,25 +256,5 @@ AS_IF([test "x$GCC" = xyes],
LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CFLAGS])
])
-dnl ----------------------------------------------------------------------
-dnl Enable -fsanitize= flags.
-dnl ----------------------------------------------------------------------
-
-m4_define(DEFAULT_SANITIZERS, [address,undefined])
-AC_ARG_ENABLE(
- sanitizers,
- AS_HELP_STRING(
- [--enable-sanitizers@<:@=comma-separated list of sanitizers@:>@],
- [Default=DEFAULT_SANITIZERS]),
-[
-case "$enableval" in
- no) sanitizers= ;;
- yes) sanitizers="-fsanitize=DEFAULT_SANITIZERS" ;;
- *) sanitizers="-fsanitize=$enableval" ;;
-esac
-CFLAGS="$CFLAGS $sanitizers"
-LDFLAGS="$LDFLAGS $sanitizers"
-])
-
AC_CONFIG_FILES([c_src/$host/Makefile:c_src/Makefile.in])
AC_OUTPUT