summaryrefslogtreecommitdiff
path: root/lib/wx/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/wx/configure.ac')
-rw-r--r--lib/wx/configure.ac23
1 files changed, 1 insertions, 22 deletions
diff --git a/lib/wx/configure.ac b/lib/wx/configure.ac
index d49399c540..6b73ddc205 100644
--- a/lib/wx/configure.ac
+++ b/lib/wx/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script. -*-m4-*-
dnl %CopyrightBegin%
dnl
-dnl Copyright Ericsson AB 2008-2022. All Rights Reserved.
+dnl Copyright Ericsson AB 2008-2023. All Rights Reserved.
dnl
dnl Licensed under the Apache License, Version 2.0 (the "License");
dnl you may not use this file except in compliance with the License.
@@ -712,27 +712,6 @@ AS_IF([test "x$GCC" = xyes],
LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CXXFLAGS])
])
-dnl ----------------------------------------------------------------------
-dnl Enable -fsanitize= flags.
-dnl ----------------------------------------------------------------------
-
-m4_define(DEFAULT_SANITIZERS, [address,undefined])
-AC_ARG_ENABLE(
- sanitizers,
- AS_HELP_STRING(
- [--enable-sanitizers@<:@=comma-separated list of sanitizers@:>@],
- [Default=DEFAULT_SANITIZERS]),
-[
-case "$enableval" in
- no) sanitizers= ;;
- yes) sanitizers="-fsanitize=DEFAULT_SANITIZERS" ;;
- *) sanitizers="-fsanitize=$enableval" ;;
-esac
-CFLAGS="$CFLAGS $sanitizers"
-CXXFLAGS="$CXXFLAGS $sanitizers"
-LDFLAGS="$LDFLAGS $sanitizers"
-])
-
#############################################################################
dnl