summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-07-19 22:37:39 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-07-19 22:37:39 +0000
commit4ec094649b2073767cdc762aa521042128c30fb3 (patch)
treec1384d936947399ca8fe2c9863d129475143a00d /configure.in
parent8588de9a2ebbf37d98e28a232a1959b38a1f29fa (diff)
downloadevolution-data-server-4ec094649b2073767cdc762aa521042128c30fb3.tar.gz
Enable building with Mozilla nspr and nss on Win32. No -ldl on Win32. No
2005-07-20 Tor Lillqvist <tml@novell.com> * configure.in: Enable building with Mozilla nspr and nss on Win32. No -ldl on Win32. No import library for softokn3.dll.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 2f81df737..8d1e2156d 100644
--- a/configure.in
+++ b/configure.in
@@ -147,10 +147,14 @@ case "$host" in
AC_CACHE_VAL(have_addrinfo, [have_addrinfo=yes])
NO_UNDEFINED='-no-undefined'
SOCKET_LIBS='-lws2_32'
+ DL_LIB=''
+ SOFTOKN3_LIB=''
;;
*) os_win32=no
NO_UNDEFINED=''
SOCKET_LIBS=''
+ DL_LIB='-ldl'
+ SOFTOKN3_LIB='-lsoftokn3'
;;
esac
AC_MSG_RESULT([$os_win32])
@@ -390,10 +394,10 @@ dnl If the user specifies --with-foo or --enable-nss=static, then we have to do
[Please specify the path to libnspr4.a]
[Example: --with-nspr-libs=/usr/lib])
else
- nsprlibs="-ldl $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
+ nsprlibs="$DL_LIB $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
fi
else
- nsprlibs="-ldl -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
+ nsprlibs="$DL_LIB -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
fi
AC_CACHE_CHECK([for Mozilla nspr libraries], moz_nspr_libs,
@@ -472,7 +476,7 @@ dnl If the user specifies --with-foo or --enable-nss=static, then we have to do
esac
fi
else
- nsslibs="-lssl3 -lsmime3 -lnss3 -lsoftokn3"
+ nsslibs="-lssl3 -lsmime3 -lnss3 $SOFTOKN3_LIB"
fi
AC_CACHE_CHECK([for Mozilla nss libraries], moz_nss_libs,
@@ -482,7 +486,7 @@ dnl If the user specifies --with-foo or --enable-nss=static, then we have to do
LIBS="$nsslibs $nsprlibs"
AC_TRY_LINK_FUNC(NSS_Init, moz_nss_libs="yes", moz_nss_libs="no")
if test "$moz_nss_libs" = no; then
- nsslibs="-lssl3 -lsmime3 -lnss3 -lsoftokn3"
+ nsslibs="-lssl3 -lsmime3 -lnss3 $SOFTOKN3_LIB"
LDFLAGS="$LDFLAGS -L$with_nspr_libs $nsprlibs -L$with_nss_libs $nsslibs"
AC_TRY_LINK_FUNC(NSS_Init, moz_nss_libs="yes", moz_nss_libs="no")
fi