summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-09-14 15:15:03 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-09-14 15:15:03 +0000
commit7edc07dda55247fb6b6731ad899bcaa10a932b6a (patch)
tree8b6c4165c22bc5c828fc035c943c0c2a12cf68ed /configure.in
parentd7b5999a247ee0f11eb3ec86a2446825902046b8 (diff)
downloadevolution-data-server-7edc07dda55247fb6b6731ad899bcaa10a932b6a.tar.gz
win32/README win32/Makefile.am win32/dummy.la New files. Bootstrap import
2005-09-14 Tor Lillqvist <tml@novell.com> * win32/README * win32/Makefile.am * win32/dummy.la * win32/libedataserverui.def: New files. Bootstrap import library for libedataserverui. Needed in servers/exchange/storage where libexchange-storage-1.2.la links to libedataserverui before it has been built. * configure.in: Add -ldnsapi to SOCKET_LIBS on Win32. Always enable LDAP and Exchange on Win32, don't need to test. AC_OUTPUT also win32/Makefile. * Makefile.am: Add win32 to SUBDIRS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 23408b169..12b230517 100644
--- a/configure.in
+++ b/configure.in
@@ -147,7 +147,7 @@ case "$host" in
os_win32=yes
AC_CACHE_VAL(have_addrinfo, [have_addrinfo=yes])
NO_UNDEFINED='-no-undefined'
- SOCKET_LIBS='-lws2_32'
+ SOCKET_LIBS='-lws2_32 -ldnsapi'
DL_LIB=''
SOFTOKN3_LIB=''
;;
@@ -1021,6 +1021,7 @@ esac
dnl **************************************************
dnl LDAP support.
dnl **************************************************
+if test "$os_win32" != yes; then
EVO_LDAP_CHECK(no)
case $with_openldap in
no)
@@ -1056,6 +1057,16 @@ dnl support. Make him aware of this with a warning message at the end.
msg_no_ntlm="yes"
fi
fi
+else # Win32
+LDAP_CFLAGS=""
+LDAP_LIBS="-lwldap32"
+AC_SUBST(LDAP_CFLAGS)
+AC_SUBST(LDAP_LIBS)
+AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
+AM_CONDITIONAL(ENABLE_LDAP, true)
+msg_no_ntlm=no
+msg_exchange="yes"
+fi # Win32
GLIB_REQUIRED="2.4.0"
LIBBONOBO_REQUIRED="2.4.2"
@@ -1323,6 +1334,7 @@ servers/exchange/lib/Makefile
servers/exchange/storage/Makefile
servers/exchange/storage/libexchange-storage.pc
src/Makefile
+win32/Makefile
docs/Makefile
docs/reference/Makefile
docs/reference/addressbook/Makefile