summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a0ea840c..5776499d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,7 +123,7 @@ set(libaccounts_glib_minimum_version 1.4)
set(libsignon_glib_minimum_version 1.8)
set(json_glib_minimum_version 1.0.4)
set(webkit2gtk_minimum_version 2.28.0)
-set(libcanberra_gtk_minimum_version 0.25)
+set(gsound_minimum_version 1.0)
# Load modules from the source tree
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
@@ -767,16 +767,16 @@ if(ENABLE_WEATHER)
unset(CMAKE_REQUIRED_LIBRARIES)
endif(ENABLE_WEATHER)
-# ************************************************
-# evolution-alarm-notify : Canberra-GTK for Sound
-# ************************************************
+# ********************************************************
+# evolution-alarm-notify : GSound for sound notifications
+# ********************************************************
-add_printable_option(ENABLE_CANBERRA "Enable Canberra-GTK for sound in evolution-alarm-notify" ON)
+add_printable_option(ENABLE_GSOUND "Enable GSound for sound in evolution-alarm-notify" ON)
-if(ENABLE_CANBERRA)
- pkg_check_modules_for_option(ENABLE_CANBERRA "Canberra-GTK for sound in evolution-alarm-notify" CANBERRA libcanberra-gtk3>=${libcanberra_gtk_minimum_version})
- set(HAVE_CANBERRA ON)
-endif(ENABLE_CANBERRA)
+if(ENABLE_GSOUND)
+ pkg_check_modules_for_option(ENABLE_GSOUND "GSound for sound notifications in evolution-alarm-notify" GSOUND gsound>=${gsound_minimum_version})
+ set(HAVE_GSOUND ON)
+endif(ENABLE_GSOUND)
# ******************************
# File locking