summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2017-09-24 16:04:55 +0000
committerChristos Zoulas <christos@zoulas.com>2017-09-24 16:04:55 +0000
commit3ddad464137378f3b57b27d5df6409185b6b8de7 (patch)
tree39efb5bf1cb08bdfb36900b5320de91d70eeef60 /configure.ac
parent86b2b57ca6daf3fc29e64774ba77dc2daa65c85d (diff)
downloadfile-git-3ddad464137378f3b57b27d5df6409185b6b8de7.tar.gz
Add and enable libseccomp support (Paul Moore)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 946198be..fee4eded 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,11 @@ AC_ARG_ENABLE(zlib,
[AS_HELP_STRING([--disable-zlib], [disable zlib compression support @<:@default=auto@:>@])])
AC_MSG_RESULT($enable_zlib)
+AC_MSG_CHECKING(for libseccomp support)
+AC_ARG_ENABLE(libseccomp,
+[AS_HELP_STRING([--disable-libseccomp], [disable libseccomp sandboxing @<:@default=auto@:>@])])
+AC_MSG_RESULT($enable_libseccomp)
+
AC_MSG_CHECKING(for file formats in man section 5)
AC_ARG_ENABLE(fsect-man5,
[ --enable-fsect-man5 enable file formats in man section 5],
@@ -158,6 +163,9 @@ dnl Checks for libraries
if test "$enable_zlib" != "no"; then
AC_CHECK_LIB(z, gzopen)
fi
+if test "$enable_libseccomp" != "no"; then
+ AC_CHECK_LIB(seccomp, seccomp_init)
+fi
if test "$MINGW" = 1; then
AC_CHECK_LIB(gnurx,regexec,,AC_MSG_ERROR([libgnurx is required to build file(1) with MinGW]))
fi