summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2021-12-28 11:55:59 +0100
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-13 17:37:50 +0200
commitf5efd956d90cb8fce5f1a02d804ebb2150052c84 (patch)
tree131dbfa93098e3a1e36613e983a5327d61ba1459 /CMakeLists.txt
parent20137386220fa120a5dd303b9d75f2031035830c (diff)
downloadflac-f5efd956d90cb8fce5f1a02d804ebb2150052c84.tar.gz
[CMake] Create prettier MSVC solution files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be6dd678..24d22d27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,6 +129,29 @@ if(BUILD_TESTING)
add_subdirectory("test")
endif()
+# The following folder layout is mostly for MSVC
+set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
+set_target_properties(FLAC grabbag getopt replaygain_analysis replaygain_synthesis utf8 PROPERTIES FOLDER Libraries)
+if(BUILD_CXXLIBS)
+ set_target_properties(FLAC++ PROPERTIES FOLDER Libraries)
+endif()
+if(BUILD_PROGRAMS)
+ set_target_properties(flacapp metaflac PROPERTIES FOLDER Programs)
+endif()
+if(BUILD_TESTING)
+ set_target_properties(test_libFLAC test_libs_common test_picture test_seeking test_streams test_cuesheet PROPERTIES FOLDER Tests)
+ if(BUILD_CXXLIBS)
+ set_target_properties(test_libFLAC++ PROPERTIES FOLDER Tests)
+ endif()
+endif()
+if(BUILD_EXAMPLES)
+ set_target_properties(decode_file decode_file_cxx encode_file encode_file_cxx PROPERTIES FOLDER Examples)
+endif()
+if(BUILD_UTILS)
+ set_target_properties(flacdiff flactimer PROPERTIES FOLDER Utils)
+endif()
+
configure_file(config.cmake.h.in config.h)
if(INSTALL_CMAKE_CONFIG_MODULE)