summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2013-09-25 23:26:49 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2013-09-25 23:30:15 +1000
commit899599e5066d5058109d66b56581d7ba3b33902b (patch)
tree636c129efb538aad1dc888e888b3b37aa21001a5 /configure.ac
parentbe6468d38cf282a2e09650c6e92a3400296684d0 (diff)
downloadflac-899599e5066d5058109d66b56581d7ba3b33902b.tar.gz
configure.ac : Tweaks.
* Add FLAC__ALIGN_MALLOC_DATA for x86_64. * Removes XIPH_ADD_CFLAGS([-msse]) as -msse2 implies -msse. * Fix typo. Patch-from: lvqcl <lvqcl.mail@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4ce752ef..7f63a044 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,7 +183,7 @@ esac
AM_CONDITIONAL(FLaC__SYS_DARWIN, test "x$sys_darwin" = xtrue)
AM_CONDITIONAL(FLaC__SYS_LINUX, test "x$sys_linux" = xtrue)
-if test "x$cpu_ia32" = xtrue ; then
+if test "x$cpu_ia32" = xtrue || test "x$cpu_x86_64" = xtrue ; then
AC_DEFINE(FLAC__ALIGN_MALLOC_DATA)
AH_TEMPLATE(FLAC__ALIGN_MALLOC_DATA, [define to align allocated memory on 32-byte boundaries])
fi
@@ -416,7 +416,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
fi
if test "x$asm_optimisation" = "xyes" ; then
- XIPH_ADD_CFLAGS([-msse])
XIPH_ADD_CFLAGS([-msse2])
fi
@@ -522,6 +521,6 @@ AC_MSG_RESULT([
if test x$ac_cv_c_compiler_gnu = xyes ; then
echo " GCC version : ......................... ${GCC_VERSION}"
fi
- echo " Asm optimiizations : .................. ${asm_optimisation}"
+ echo " Asm optimizations : ................... ${asm_optimisation}"
echo " Ogg/FLAC support : .................... ${have_ogg}"
echo