summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2013-03-09 08:55:37 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2013-03-09 09:18:06 +1100
commitd5b03bcc36474ff1c9f2da2dcb5212e810208a6f (patch)
tree9837db970262ded19281a89ed0909788eaedb65e /configure.ac
parentae663c36af889adadd10249709aeae8f6b6b69f0 (diff)
downloadflac-d5b03bcc36474ff1c9f2da2dcb5212e810208a6f.tar.gz
configure.ac : Don't enable stack protector for mingw* host_os.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b99f4027..24696fea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,10 +356,6 @@ fi
XIPH_GCC_VERSION
-XIPH_ADD_CFLAGS([-Wextra])
-XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
-XIPH_ADD_CFLAGS([-fstack-protector --param ssp-buffer-size=4])
-
if test x$ac_cv_c_compiler_gnu = xyes ; then
if test x$enable_gcc_werror = "xyes" ; then
CFLAGS="-Wall -Wextra -Werror $CFLAGS"
@@ -374,6 +370,18 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
fi
+XIPH_ADD_CFLAGS([-Wextra])
+XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
+
+case "$host_os" in
+ mingw32msvc | mingw32)
+ # Disable for MinGW. Had reports of it not working.
+ ;;
+ *)
+ XIPH_ADD_CFLAGS([-fstack-protector --param ssp-buffer-size=4])
+ ;;
+ esac
+
#@@@
AM_CONDITIONAL(FLaC__HAS_AS__TEMPORARILY_DISABLED, test "yes" = "no")
AM_CONDITIONAL(FLaC__HAS_GAS__TEMPORARILY_DISABLED, test "yes" = "no")