summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2016-01-24 08:21:23 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2016-01-24 08:21:26 +1100
commit924cade2d94105406737c6427b9312ea69ab839f (patch)
treece32412892e2e341913706d72f3d32b8be99880a /configure.ac
parent29029748303ea242d11e5a1ae6973835832a0962 (diff)
downloadflac-924cade2d94105406737c6427b9312ea69ab839f.tar.gz
Fix linking of microbenchmark program
On some setups, benchmark_residual linkage fails with an undefined reference to clock_gettime(). Adding -lrt fixes that. Patch-from: Ozkan Sezer <sezeroz@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 993ac336..99c471d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,6 +437,11 @@ if test x$enable_stack_smash_protection = "xyes" ; then
XIPH_GXX_STACK_PROTECTOR
fi
+if test "x$sys_linux" = xtrue ; then
+ LIB_CLOCK_GETTIME=-lrt
+ fi
+AC_SUBST(LIB_CLOCK_GETTIME)
+
AC_CONFIG_FILES([ \
Makefile \
src/Makefile \