summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2016-01-04 11:29:03 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2016-01-04 11:47:21 +1100
commita3224c0434ce2c11f37bbeb4bb44a343771a6f7f (patch)
tree1fb6cf390ce68f329102ec480428980d5e60b15c /configure.ac
parent6cc1cbad2c40a4406fd911445b86b3df2291dd79 (diff)
downloadflac-a3224c0434ce2c11f37bbeb4bb44a343771a6f7f.tar.gz
configure.ac: Add --enable-64-bit-words option
The old 32 bit words the default which can be overridded with this configure option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 46cb916b..993ac336 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,6 +269,15 @@ AC_ARG_ENABLE(werror,
AC_ARG_ENABLE(stack-smash-protection,
AC_HELP_STRING([--enable-stack-smash-protection], [Enable GNU GCC stack smash protection]))
+AC_ARG_ENABLE(64-bit-words,
+ AC_HELP_STRING([--enable-64-bit-words], [Set FLAC__BYTES_PER_WORD to 8 (4 is the default)]))
+if test "x$enable_64_bit_words" = xyes ; then
+ AC_DEFINE_UNQUOTED([ENABLE_64_BIT_WORDS],1,[Set FLAC__BYTES_PER_WORD to 8 (4 is the default)])
+else
+ AC_DEFINE_UNQUOTED([ENABLE_64_BIT_WORDS],0)
+ fi
+AC_SUBST(ENABLE_64_BIT_WORDS)
+
AC_ARG_ENABLE(valgrind-testing,
AC_HELP_STRING([--enable-valgrind-testing], [Run all tests inside Valgrind]),
[case "${enableval}" in