summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Matthews <tmatth@videolan.org>2015-04-11 01:05:30 -0400
committerErik de Castro Lopo <erikd@mega-nerd.com>2015-04-19 06:27:20 +1000
commita84587061cab4d55fa2668ea431d3b61e711c8a3 (patch)
treebcebd7c9bd85d1c2f4e658cd902637fa90254d3d /configure.ac
parent1ed65e560039a1b729720bbc5d9b72f72bab2152 (diff)
downloadflac-a84587061cab4d55fa2668ea431d3b61e711c8a3.tar.gz
configure: Only use -mstackrealign on i686 for mingw32/os2
Signed-off-by: Erik de Castro Lopo <erikd@mega-nerd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eb9b0cc3..6f34c66f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,11 +399,17 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
XIPH_ADD_CFLAGS([-msse2])
- XIPH_ADD_CFLAGS([-mstackrealign])
fi
fi
+case "$host_os" in
+ "mingw32"|"os2")
+ if test "$host_cpu" = "i686"; then
+ XIPH_ADD_CFLAGS([-mstackrealign])
+ fi
+ esac
+
XIPH_ADD_CFLAGS([-Wextra])
if test x$enable_werror = "xyes" ; then