summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2013-11-22 18:13:36 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2013-11-22 18:13:40 +1100
commita6a4b6f2052829c205319ecb0f5df553baedc9a4 (patch)
tree2f97b1c5f9b2bcc72e7eb1187fbda801eef8d93a /configure.ac
parent8e2eea6322348de674ebb4d3a2295131c92b0c49 (diff)
downloadflac-a6a4b6f2052829c205319ecb0f5df553baedc9a4.tar.gz
Detect Clang masquerading as GCC.
Autoconf detects the Clang compiler as GNU GCC (clang sets defines like __GNUC__ etc) but Clang is *not* completely compatible. If we detect Clang we set ac_vc_c_compiler_gnu to 'no'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f63a044..19320a4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,8 @@ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
LT_INIT([win32-dll disable-static pic-only])
AM_PROG_AS
AC_PROG_CXX
+XIPH_C_COMPILER_IS_CLANG
+XIPH_GCC_REALLY_IS_GCC
AC_PROG_MAKE_SET
AC_SYS_LARGEFILE
@@ -521,6 +523,7 @@ AC_MSG_RESULT([
if test x$ac_cv_c_compiler_gnu = xyes ; then
echo " GCC version : ......................... ${GCC_VERSION}"
fi
+ echo " Compiler is Clang : ................... ${xiph_cv_c_compiler_clang}"
echo " Asm optimizations : ................... ${asm_optimisation}"
echo " Ogg/FLAC support : .................... ${have_ogg}"
echo