summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2014-07-13 21:19:48 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2014-09-17 23:21:39 +1000
commitb60f16bbc818729a0cf3b9c22cd6b24e7febd85b (patch)
tree7200c4322b2986b4356ea08cd320df46b3b9a3d3 /configure.ac
parentd399e31ec65f0282481108f9c7bc892f6eaf00cb (diff)
downloadflac-b60f16bbc818729a0cf3b9c22cd6b24e7febd85b.tar.gz
Remove old/broken PPC/Altivec code.
* Removes FLAC__lpc_restore_signal_asm_ppc_altivec_16* from lpc.h and stream_decoder.c * Removes PPC-specific code from cpu.c and cpu.h * Removes PPC stuff from libFLAC/Makefile.lite and build/*.mk * Removes as/gas/PPC-specific stuff from configure.ac and libFLAC/Makefile.am* * Removes libFLAC/ppc folder and remove "src/libFLAC/ppc*/Makefile" lines from configure.ac Patch-from: lvqcl <lvqcl.mail@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index f74bb1d6..db5402d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,25 +358,6 @@ AC_DEFINE(FLAC__HAS_NASM)
AH_TEMPLATE(FLAC__HAS_NASM, [define if you are compiling for x86 and have the NASM assembler])
fi
-# only matters for PowerPC
-AC_CHECK_PROGS(AS, as, as)
-AC_CHECK_PROGS(GAS, gas, gas)
-
-# try -v (apple as) and --version (gas) at the same time
-test "$AS" = "as" && as --version -v < /dev/null 2>&1 | grep Apple >/dev/null || AS=gas
-
-AM_CONDITIONAL(FLaC__HAS_AS, test "$AS" = "as")
-AM_CONDITIONAL(FLaC__HAS_GAS, test "$AS" = "gas")
-if test "$AS" = "as" ; then
-AC_DEFINE(FLAC__HAS_AS)
-AH_TEMPLATE(FLAC__HAS_AS, [define if you are compiling for PowerPC and have the 'as' assembler])
-fi
-if test "$AS" = "gas" ; then
-# funniest. macro. ever.
-AC_DEFINE(FLAC__HAS_GAS)
-AH_TEMPLATE(FLAC__HAS_GAS, [define if you are compiling for PowerPC and have the 'gas' assembler])
-fi
-
if test "x$debug" = xtrue; then
CPPFLAGS="-DDEBUG $CPPFLAGS"
CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
@@ -431,25 +412,17 @@ if test x$enable_werror = "xyes" ; then
AC_LANG_POP([C++])
fi
-
if test x$enable_stack_smash_protection = "xyes" ; then
XIPH_GCC_STACK_PROTECTOR
XIPH_GXX_STACK_PROTECTOR
fi
-#@@@
-AM_CONDITIONAL(FLaC__HAS_AS__TEMPORARILY_DISABLED, test "yes" = "no")
-AM_CONDITIONAL(FLaC__HAS_GAS__TEMPORARILY_DISABLED, test "yes" = "no")
-
AC_CONFIG_FILES([ \
Makefile \
src/Makefile \
src/libFLAC/Makefile \
src/libFLAC/flac.pc \
src/libFLAC/ia32/Makefile \
- src/libFLAC/ppc/Makefile \
- src/libFLAC/ppc/as/Makefile \
- src/libFLAC/ppc/gas/Makefile \
src/libFLAC/include/Makefile \
src/libFLAC/include/private/Makefile \
src/libFLAC/include/protected/Makefile \