summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2014-07-26 18:24:49 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2014-07-26 18:24:52 +1000
commit221bdc409d811b7b432c41e9800149c4cdc446ad (patch)
tree06b7baec2a01b4a5b1a80ba9506ce0798a9a9f5a /configure.ac
parent865041b7ca1f0a10c536723629ac7d3b9f9a147d (diff)
downloadflac-221bdc409d811b7b432c41e9800149c4cdc446ad.tar.gz
configure.ac : Set default CFLAGS to something sensible.
Preserve the CFLAGS value from the time the configure script is run.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d3c302aa..c81c4d38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,11 +382,7 @@ if test "x$debug" = xtrue; then
CFLAGS="-g $CFLAGS"
else
CPPFLAGS="-DNDEBUG $CPPFLAGS"
- if test "x$GCC" = xyes; then
- if test "x$user_cflags" = x; then
- CFLAGS="-O3 -funroll-loops -Wall -W -Winline"
- fi
- fi
+ CFLAGS="-O3 -funroll-loops -Wall -W -Winline $CFLAGS"
fi
XIPH_GCC_VERSION