summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2015-03-31 18:21:38 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2015-03-31 10:14:29 +1100
commit1ed65e560039a1b729720bbc5d9b72f72bab2152 (patch)
tree566671dcebfe0dad8c6e94fbe124b896fa02e5de /configure.ac
parentef9f7998fd358b2812a7296fe1c5aed221bade5f (diff)
downloadflac-1ed65e560039a1b729720bbc5d9b72f72bab2152.tar.gz
configure.ac : Add -mstackrealign whenever we add -msse2.
There have been some (pretty much unconfirmed) reports of problems with SSE enabled but without this stack alignment flag.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2dcc6987..eb9b0cc3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,6 +399,7 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
XIPH_ADD_CFLAGS([-msse2])
+ XIPH_ADD_CFLAGS([-mstackrealign])
fi
fi