summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2009-01-03 01:35:56 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2009-01-03 01:35:56 +0000
commit75d35cfe0bfa47e5d12ca57cfd6a5b4bf67c88ec (patch)
treedc6b9130ccf654576224e695472a601b8060daed /configure.in
parente5c6439074b4174183627ae23b834e0e8278f83e (diff)
downloadflac-75d35cfe0bfa47e5d12ca57cfd6a5b4bf67c88ec.tar.gz
proper handling of variable length arrays (SF#2002481 https://sourceforge.net/tracker2/?func=detail&aid=2002481&group_id=13478&atid=113478)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cede98f8..4722c573 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,16 @@ AC_CHECK_SIZEOF(void*,0)
#@@@ new name is AC_CONFIG_HEADERS
AM_CONFIG_HEADER(config.h)
+AC_LANG_PUSH(C++)
+# c++ flavor first
+AC_C_VARARRAYS
+if test $ac_cv_c_vararrays = yes; then
+ AC_DEFINE([HAVE_CXX_VARARRAYS], 1, [Define to 1 if C++ supports variable-length arrays.])
+fi
+AC_LANG_POP(C++)
+# c flavor
+AC_C_VARARRAYS
+
AC_C_BIGENDIAN
AC_CHECK_TYPES(socklen_t, [], [])