summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2007-08-01 03:03:51 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2007-08-01 03:03:51 +0000
commit330fc08a3f15ce0bd86f70069b14dd5474763ed9 (patch)
treed4c4ab9d628aa4581914dc3e60c4476940e02156 /configure.in
parent12d3a41896ea18d572e3a5b91181b9d2d95a347b (diff)
downloadflac-330fc08a3f15ce0bd86f70069b14dd5474763ed9.tar.gz
more mingw fixes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8826f191..9bbae797 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,7 @@ esac
AM_CONDITIONAL(FLaC__CPU_IA32, test "x$cpu_ia32" = xtrue)
AM_CONDITIONAL(FLaC__CPU_PPC, test "x$cpu_ppc" = xtrue)
AM_CONDITIONAL(FLaC__CPU_SPARC, test "x$cpu_sparc" = xtrue)
+
case "$host" in
i386-*-openbsd3.[[0-3]]) OBJ_FORMAT=aoutb ;;
*-*-cygwin|*mingw*) OBJ_FORMAT=win32 ;;
@@ -81,6 +82,14 @@ case "$host" in
*) OBJ_FORMAT=elf ;;
esac
AC_SUBST(OBJ_FORMAT)
+
+# only needed because of ntohl() usage, can get rid of after that's gone:
+case "$host" in
+ *-*-cygwin|*mingw*) MINGW_WINSOCK_LIBS=-lwsock32 ;;
+ *) MINGW_WINSOCK_LIBS= ;;
+esac
+AC_SUBST(MINGW_WINSOCK_LIBS)
+
case "$host" in
*-pc-linux-gnu)
sys_linux=true