summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2007-09-12 02:42:05 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2007-09-12 02:42:05 +0000
commit44937a765286e974ee785d663de2b299c99ed29e (patch)
tree87cdf06005ef1f40b6bb37fb5a6f0737e98b0de1 /examples/Makefile.am
parent546ba794ca7cc2c2995c6744c48099c554d3ed57 (diff)
downloadflac-44937a765286e974ee785d663de2b299c99ed29e.tar.gz
add new top level examples/ directory with one example for now (example_c_decode_file)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 00000000..64a49f3c
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,27 @@
+# FLAC - Free Lossless Audio Codec
+# Copyright (C) 2001,2002,2003,2004,2005,2006,2007 Josh Coalson
+#
+# This file is part the FLAC project. FLAC is comprised of several
+# components distributed under difference licenses. The codec libraries
+# are distributed under Xiph.Org's BSD-like license (see the file
+# COPYING.Xiph in this distribution). All other programs, libraries, and
+# plugins are distributed under the GPL (see COPYING.GPL). The documentation
+# is distributed under the Gnu FDL (see COPYING.FDL). Each file in the
+# FLAC distribution contains at the top the terms under which it may be
+# distributed.
+#
+# Since this particular file is relevant to all components of FLAC,
+# it may be distributed under the Xiph.Org license, which is the least
+# restrictive of those mentioned above. See the file COPYING.Xiph in this
+# distribution.
+
+if FLaC__WITH_CPPLIBS
+CPPLIBS_DIRS = cpp
+endif
+
+SUBDIRS = c $(CPPLIBS_DIRS)
+
+EXTRA_DIST = \
+ examples.dsp \
+ Makefile.lite \
+ README