summaryrefslogtreecommitdiff
path: root/examples/c/decode/file/Makefile.am
diff options
context:
space:
mode:
authorCristian Rodríguez <crrodriguez@opensuse.org>2012-04-07 19:24:21 -0300
committerErik de Castro Lopo <erikd@mega-nerd.com>2012-04-08 09:03:03 +1000
commit9b7cb22f84bcdfaea83457efcb1ad0b144e9708b (patch)
treead9941cb1a6d8ff5b66791890dd89874ceeb09fe /examples/c/decode/file/Makefile.am
parent8340ab3bc8f5bb35bb0ecf95ac4fb86ab576de62 (diff)
downloadflac-9b7cb22f84bcdfaea83457efcb1ad0b144e9708b.tar.gz
Update and improve autotools build
- INCLUDES is deprecated, and CPPFLAGS is an user-defined variable, use the proper AM_CPPFLAGS instead - Remove FLAC__INLINE definition, providing proper replacement for MSVC compilers. - Detect if we have C99 's lround and provide a replacement for windows...
Diffstat (limited to 'examples/c/decode/file/Makefile.am')
-rw-r--r--examples/c/decode/file/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/c/decode/file/Makefile.am b/examples/c/decode/file/Makefile.am
index 11a48bf6..30f86916 100644
--- a/examples/c/decode/file/Makefile.am
+++ b/examples/c/decode/file/Makefile.am
@@ -19,7 +19,7 @@ EXTRA_DIST = \
Makefile.lite \
example_c_decode_file.dsp \
example_c_decode_file.vcproj
-
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
noinst_PROGRAMS = example_c_decode_file
example_c_decode_file_LDADD = \
$(top_builddir)/src/libFLAC/libFLAC.la \