summaryrefslogtreecommitdiff
path: root/microbench/Makefile.am
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2015-09-01 03:38:43 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2015-09-01 04:14:17 +1000
commit95fc3bf314e73142a0e1e6fdb524623e27739e8a (patch)
tree69f87923097afbe9b11478f89f6ff2ad90b15ca3 /microbench/Makefile.am
parente48ca8d4d71ab0521b90062f2386782d26bde5d0 (diff)
downloadflac-95fc3bf314e73142a0e1e6fdb524623e27739e8a.tar.gz
Add first micro-benchmark
Diffstat (limited to 'microbench/Makefile.am')
-rw-r--r--microbench/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/microbench/Makefile.am b/microbench/Makefile.am
new file mode 100644
index 00000000..4ed70f6e
--- /dev/null
+++ b/microbench/Makefile.am
@@ -0,0 +1,37 @@
+# FLAC - Free Lossless Audio Codec
+# Copyright (C) 2015 Xiph.Org Foundation
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# - Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# - Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# - Neither the name of the Xiph.org Foundation nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src/libFLAC/include
+
+noinst_PROGRAMS = benchmark_residual
+
+
+benchmark_residual_SOURCES = benchmark_residual.c util.c