summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2007-08-29 05:45:19 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2007-08-29 05:45:19 +0000
commit367c1587f52e0300f97525ecb96715f484501e8c (patch)
tree8c56edb20a63e19a5018b041f2199189c233ae8b /src/Makefile.am
parent56378245964cdcf8ba993b1d4c01cf2836118c08 (diff)
downloadflac-367c1587f52e0300f97525ecb96715f484501e8c.tar.gz
add --disable-cpplibs configure option (SF#1723295: https://sourceforge.net/tracker/index.php?func=detail&aid=1723295&group_id=13478&atid=313478
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 298eb17e..131383e6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,9 +19,12 @@ if FLaC__HAS_XMMS
XMMS_DIRS = plugin_common plugin_xmms
endif
+if FLaC__WITH_CPPLIBS
+CPPLIBS_DIRS = libFLAC++ test_libFLAC++
+endif
+
SUBDIRS = \
libFLAC \
- libFLAC++ \
share \
flac \
metaflac \
@@ -31,9 +34,9 @@ SUBDIRS = \
test_grabbag \
test_libs_common \
test_libFLAC \
- test_libFLAC++ \
test_seeking \
- test_streams
+ test_streams \
+ $(CPPLIBS_DIRS)
EXTRA_DIST = \
Makefile.lite