summaryrefslogtreecommitdiff
path: root/src/flac/CMakeLists.txt
diff options
context:
space:
mode:
authorevpobr <evpobr@gmail.com>2020-05-02 10:54:28 +0500
committerErik de Castro Lopo <erikd@mega-nerd.com>2020-05-03 17:13:50 +1000
commite0b62a61a7b65aef187b038454925a34fa315125 (patch)
tree42cd4bd9f1924528b722fe0fcb6402c17348d94f /src/flac/CMakeLists.txt
parent7a35c528495b6d8a51e87e007f6810b5553101bc (diff)
downloadflac-e0b62a61a7b65aef187b038454925a34fa315125.tar.gz
Bunch of CMake fixes
* Add more Git ignore patterns * Fix Ogg dependency handling (closes #203) * Remove unneeded compiler flag (closes #204) * Fix Visual Studio DLL build error error C2491: 'flac_internal_rename_utf8': definition of dllimport function not allowed (closes #205) * Add alias targets * Reduce number of CMake files * Improve CMake intrinsics detection
Diffstat (limited to 'src/flac/CMakeLists.txt')
-rw-r--r--src/flac/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/flac/CMakeLists.txt b/src/flac/CMakeLists.txt
index ea4f6873..c227cd87 100644
--- a/src/flac/CMakeLists.txt
+++ b/src/flac/CMakeLists.txt
@@ -9,16 +9,15 @@ add_executable(flacapp
main.c
local_string_utils.c
utils.c
- vorbiscomment.c)
+ vorbiscomment.c
+ $<$<BOOL:${WIN32}>:../../include/share/win_utf8_io.h>
+ $<$<BOOL:${WIN32}>:../share/win_utf8_io/win_utf8_io.c>)
set_property(TARGET flacapp PROPERTY RUNTIME_OUTPUT_NAME flac)
target_link_libraries(flacapp
FLAC
getopt
replaygain_synthesis
utf8)
-if(TARGET win_utf8_io)
- target_link_libraries(flacapp win_utf8_io)
-endif()
install(TARGETS flacapp EXPORT targets
RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")