summaryrefslogtreecommitdiff
path: root/src/libFLAC/ia32/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2001-07-22 07:26:58 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2001-07-22 07:26:58 +0000
commite06969359f91031267b9e8b3aac73624f26e5dcb (patch)
treeaa4bc584bb1bf4371819191ac08ff8c73ffe5593 /src/libFLAC/ia32/Makefile.am
parent21f692bb254bd268ed663a2b331cc2f99cfe5f3a (diff)
downloadflac-e06969359f91031267b9e8b3aac73624f26e5dcb.tar.gz
revert to using libtool to generate the convenience library
Diffstat (limited to 'src/libFLAC/ia32/Makefile.am')
-rw-r--r--src/libFLAC/ia32/Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/src/libFLAC/ia32/Makefile.am b/src/libFLAC/ia32/Makefile.am
index 82295c53..bfdd1950 100644
--- a/src/libFLAC/ia32/Makefile.am
+++ b/src/libFLAC/ia32/Makefile.am
@@ -20,16 +20,12 @@ SUFFIXES = .nasm .lo
STRIP_FPIC = sh $(top_srcdir)/strip_fPIC.sh
-.nasm.o:
- $(NASM) -f $(OBJ_FORMAT) -d OBJ_FORMAT_$(OBJ_FORMAT) $< -o $@
+.nasm.lo:
+ $(LIBTOOL) --mode=compile $(STRIP_FPIC) $(NASM) -f $(OBJ_FORMAT) -d OBJ_FORMAT_$(OBJ_FORMAT) $< -o $@
-# patch from Ben for the above rule that may be needed with new libtool:
-#.nasm.lo:
-# $(LIBTOOL) --tag=CC --mode=compile \
-# $(STRIP_FPIC) $(NASM) -f $(OBJ_FORMAT) -d OBJ_FORMAT_$(OBJ_FORMAT) $<
-
-noinst_LIBRARIES = libFLAC-asm.a
-libFLAC_asm_a_SOURCES = \
+noinst_LTLIBRARIES = libFLAC-asm.la
+libFLAC_asm_la_SOURCES = \
cpu_asm.nasm \
fixed_asm.nasm \
- lpc_asm.nasm
+ lpc_asm.nasm \
+ nasm.h