summaryrefslogtreecommitdiff
path: root/src/metaflac/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaliy Kirsanov <krokoziabla@yandex-team.ru>2019-03-31 23:04:45 +0300
committerErik de Castro Lopo <erikd@mega-nerd.com>2019-05-04 11:41:48 +1000
commitc39718d7a36405114f9ed0b1a7acaef64ea88131 (patch)
tree3d3633d0af41f00ccb6f0ec4dc48f9b018d5ff7c /src/metaflac/CMakeLists.txt
parent12ec86c6188aef9ebd4b9bd0393eab7326e185fc (diff)
downloadflac-c39718d7a36405114f9ed0b1a7acaef64ea88131.tar.gz
CMake support added
Diffstat (limited to 'src/metaflac/CMakeLists.txt')
-rw-r--r--src/metaflac/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/metaflac/CMakeLists.txt b/src/metaflac/CMakeLists.txt
new file mode 100644
index 00000000..8f99d646
--- /dev/null
+++ b/src/metaflac/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_executable(metaflac
+ main.c
+ operations.c
+ operations_shorthand_cuesheet.c
+ operations_shorthand_picture.c
+ operations_shorthand_seektable.c
+ operations_shorthand_streaminfo.c
+ operations_shorthand_vorbiscomment.c
+ options.c
+ usage.c
+ utils.c)
+target_link_libraries(metaflac FLAC-static grabbag getopt utf8)
+
+install(TARGETS metaflac EXPORT targets
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")