summaryrefslogtreecommitdiff
path: root/src/plugin_common/Makefile.am
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-15 10:37:02 +0100
committerErik de Castro Lopo <erikd@mega-nerd.com>2017-01-19 20:47:26 +1100
commitb3ece71334540aa35de30c821ae83acc1c503b01 (patch)
treec0d12f29ab6c80e1b7ae6ce8b63c1c50cc754dc2 /src/plugin_common/Makefile.am
parent09b8224804545338b66aa985c0f9eba949e0ede5 (diff)
downloadflac-b3ece71334540aa35de30c821ae83acc1c503b01.tar.gz
Do not override CFLAGS, as CFLAGS is a user flag.
* Furthermore, use NDEBUG globally to detect the presence of building with more debug output information. AX_CHECK_ENABLE_DEBUG is easier to use, and nowadays Gnome has also switched to it from its own custom solution. Signed-off-by: Erik de Castro Lopo <erikd@mega-nerd.com>
Diffstat (limited to 'src/plugin_common/Makefile.am')
-rw-r--r--src/plugin_common/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/plugin_common/Makefile.am b/src/plugin_common/Makefile.am
index 6e9e3ed3..a528fb45 100644
--- a/src/plugin_common/Makefile.am
+++ b/src/plugin_common/Makefile.am
@@ -37,9 +37,3 @@ libplugin_common_la_SOURCES = \
EXTRA_DIST = \
Makefile.lite \
README
-
-debug:
- $(MAKE) all CFLAGS="@DEBUG@"
-
-profile:
- $(MAKE) all CFLAGS="@PROFILE@"