summaryrefslogtreecommitdiff
path: root/src/share/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorВиталий Кирсанов <krokoziabla@gmail.com>2019-04-26 23:38:10 +0300
committerErik de Castro Lopo <erikd@mega-nerd.com>2019-05-04 11:41:48 +1000
commit1cb968a7d45eea5f45451981c32df79e5b798739 (patch)
treeb00b5a07c230388b89e80162ea123c564576287b /src/share/getopt/CMakeLists.txt
parent5d81610eb57b45963053f1380c35005a8a6185fb (diff)
downloadflac-1cb968a7d45eea5f45451981c32df79e5b798739.tar.gz
Fixed dependencies on win_utf8_io
Diffstat (limited to 'src/share/getopt/CMakeLists.txt')
-rw-r--r--src/share/getopt/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/share/getopt/CMakeLists.txt b/src/share/getopt/CMakeLists.txt
index 1e5f5162..83b530e5 100644
--- a/src/share/getopt/CMakeLists.txt
+++ b/src/share/getopt/CMakeLists.txt
@@ -1,4 +1,11 @@
-check_include_file("libintl.h" HAVE_LIBINTL_H)
check_include_file("string.h" HAVE_STRING_H)
+find_package(Intl)
+
add_library(getopt STATIC getopt.c getopt1.c)
+
+if(Intl_FOUND)
+ target_include_directories(getopt PRIVATE ${Intl_INCLUDE_DIRS})
+ target_link_libraries(getopt PUBLIC ${Intl_LIBRARIES})
+ target_compile_definitions(getopt PRIVATE HAVE_LIBINTL_H)
+endif()