summaryrefslogtreecommitdiff
path: root/src/test_streams/Makefile.am
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2013-04-01 19:57:13 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2013-04-01 19:57:13 +1100
commit2199d086921eb37d249cae0731f334556ec6209d (patch)
tree5add730a244929f20e8863a8afd6efbd9bc2acbe /src/test_streams/Makefile.am
parentb3c3e2ac4fcac9d9b178ad240976634d52d5eece (diff)
downloadflac-2199d086921eb37d249cae0731f334556ec6209d.tar.gz
Enable utf8 I/O stuff when compiling with MinGW.
Diffstat (limited to 'src/test_streams/Makefile.am')
-rw-r--r--src/test_streams/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/test_streams/Makefile.am b/src/test_streams/Makefile.am
index de0d6935..7942dc57 100644
--- a/src/test_streams/Makefile.am
+++ b/src/test_streams/Makefile.am
@@ -24,6 +24,10 @@ noinst_PROGRAMS = test_streams
test_streams_SOURCES = \
main.c
-test_streams_LDADD = $(top_builddir)/src/share/grabbag/libgrabbag.la -lm
+if OS_IS_WINDOWS
+win_utf8_lib = $(top_builddir)/src/share/win_utf8_io/libwin_utf8_io.la
+endif
+
+test_streams_LDADD = $(win_utf8_lib) $(top_builddir)/src/share/grabbag/libgrabbag.la -lm
CLEANFILES = test_streams.exe