summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 88e0995f..c03e36b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,12 +126,15 @@ AM_CONDITIONAL(FLaC__CPU_PPC_SPE, test "x$abi_spe" = xtrue)
os_is_windows=no
case "$host" in
- *-*-cygwin|*mingw*|*emx*)
+ *-*-cygwin|*mingw*)
# define this variable for enabling strict exports with libtool; for now, it's supported by Win32 and OS/2
LT_NO_UNDEFINED="-no-undefined"
CPPFLAGS="-D__MSVCRT_VERSION__=0x0601 $CPPFLAGS"
os_is_windows=yes
;;
+ *emx*)
+ LT_NO_UNDEFINED="-no-undefined"
+ ;;
*)
LT_NO_UNDEFINED=
;;