summaryrefslogtreecommitdiff
path: root/microbench/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'microbench/CMakeLists.txt')
-rw-r--r--microbench/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/microbench/CMakeLists.txt b/microbench/CMakeLists.txt
new file mode 100644
index 00000000..64042059
--- /dev/null
+++ b/microbench/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(MSVC)
+ return()
+endif()
+
+set(CMAKE_REQUIRED_LIBRARIES rt)
+check_function_exists(clock_gettime HAVE_CLOCK_GETTIME)
+
+add_compile_definitions(
+ $<$<BOOL:${HAVE_CLOCK_GETTIME}>:HAVE_CLOCK_GETTIME>
+ $<$<BOOL:${APPLE}>:FLAC__SYS_DARWIN>)
+
+add_executable(benchmark_residual benchmark_residual.c util.c)
+target_include_directories(benchmark_residual PRIVATE
+ "$<TARGET_PROPERTY:FLAC-static,SOURCE_DIR>/include")
+target_link_libraries(benchmark_residual
+ FLAC-static
+ $<$<BOOL:${HAVE_CLOCK_GETTIME}>:rt>)