summaryrefslogtreecommitdiff
path: root/src/flac/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/flac/CMakeLists.txt')
-rw-r--r--src/flac/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/flac/CMakeLists.txt b/src/flac/CMakeLists.txt
index ea4f6873..c227cd87 100644
--- a/src/flac/CMakeLists.txt
+++ b/src/flac/CMakeLists.txt
@@ -9,16 +9,15 @@ add_executable(flacapp
main.c
local_string_utils.c
utils.c
- vorbiscomment.c)
+ vorbiscomment.c
+ $<$<BOOL:${WIN32}>:../../include/share/win_utf8_io.h>
+ $<$<BOOL:${WIN32}>:../share/win_utf8_io/win_utf8_io.c>)
set_property(TARGET flacapp PROPERTY RUNTIME_OUTPUT_NAME flac)
target_link_libraries(flacapp
FLAC
getopt
replaygain_synthesis
utf8)
-if(TARGET win_utf8_io)
- target_link_libraries(flacapp win_utf8_io)
-endif()
install(TARGETS flacapp EXPORT targets
RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")