summaryrefslogtreecommitdiff
path: root/src/flac/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/flac/CMakeLists.txt')
-rw-r--r--src/flac/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/flac/CMakeLists.txt b/src/flac/CMakeLists.txt
new file mode 100644
index 00000000..3fb2e2f7
--- /dev/null
+++ b/src/flac/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 3.12)
+
+check_include_file("sys/ioctl.h" HAVE_SYS_IOCTL_H)
+check_include_file("termios.h" HAVE_TERMIOS_H)
+
+add_compile_definitions(
+ $<$<BOOL:${HAVE_SYS_IOCTL_H}>:HAVE_SYS_IOCTL_H>
+ $<$<BOOL:${HAVE_TERMIOS_H}>:HAVE_TERMIOS_H>)
+
+add_executable(flac
+ analyze.c
+ decode.c
+ encode.c
+ foreign_metadata.c
+ main.c
+ local_string_utils.c
+ utils.c
+ vorbiscomment.c)
+target_link_libraries(flac
+ FLAC-static
+ getopt
+ grabbag
+ replaygain_synthesis
+ utf8)
+
+install(TARGETS flac EXPORT targets
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")