summaryrefslogtreecommitdiff
path: root/src/metaflac/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/metaflac/CMakeLists.txt')
-rw-r--r--src/metaflac/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/metaflac/CMakeLists.txt b/src/metaflac/CMakeLists.txt
index 77eafbdb..677ab1a5 100644
--- a/src/metaflac/CMakeLists.txt
+++ b/src/metaflac/CMakeLists.txt
@@ -8,11 +8,10 @@ add_executable(metaflac
operations_shorthand_vorbiscomment.c
options.c
usage.c
- utils.c)
+ utils.c
+ $<$<BOOL:${WIN32}>:../../include/share/win_utf8_io.h>
+ $<$<BOOL:${WIN32}>:../share/win_utf8_io/win_utf8_io.c>)
target_link_libraries(metaflac FLAC getopt utf8)
-if(TARGET win_utf8_io)
- target_link_libraries(metaflac win_utf8_io)
-endif()
install(TARGETS metaflac EXPORT targets
RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")