summaryrefslogtreecommitdiff
path: root/src/metaflac/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/metaflac/CMakeLists.txt')
-rw-r--r--src/metaflac/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/metaflac/CMakeLists.txt b/src/metaflac/CMakeLists.txt
new file mode 100644
index 00000000..8f99d646
--- /dev/null
+++ b/src/metaflac/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_executable(metaflac
+ main.c
+ operations.c
+ operations_shorthand_cuesheet.c
+ operations_shorthand_picture.c
+ operations_shorthand_seektable.c
+ operations_shorthand_streaminfo.c
+ operations_shorthand_vorbiscomment.c
+ options.c
+ usage.c
+ utils.c)
+target_link_libraries(metaflac FLAC-static grabbag getopt utf8)
+
+install(TARGETS metaflac EXPORT targets
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")