summaryrefslogtreecommitdiff
path: root/src/share/getopt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/share/getopt/CMakeLists.txt')
-rw-r--r--src/share/getopt/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/share/getopt/CMakeLists.txt b/src/share/getopt/CMakeLists.txt
index a247336c..1e5f5162 100644
--- a/src/share/getopt/CMakeLists.txt
+++ b/src/share/getopt/CMakeLists.txt
@@ -1,12 +1,4 @@
-cmake_minimum_required(VERSION 3.12)
-
check_include_file("libintl.h" HAVE_LIBINTL_H)
check_include_file("string.h" HAVE_STRING_H)
-add_compile_definitions(
- $<$<BOOL:${HAVE_LIBINTL_H}>:HAVE_LIBINTL_H>
- $<$<BOOL:${HAVE_STRING_H}>:HAVE_STRING_H>)
-
-add_library(getopt STATIC
- getopt.c
- getopt1.c)
+add_library(getopt STATIC getopt.c getopt1.c)