summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2017-03-22 14:50:48 -0400
committerAlexander Larsson <alexander.larsson@gmail.com>2017-03-27 10:42:36 +0200
commit2618a19716856d2b107acc0b5b63838e1379ef45 (patch)
tree3a0f557bcb8a12f1055ab3ad18672529313746c1 /Makefile.am
parent64fd2c2a8d91969dbac7041124afefbd63905fbe (diff)
downloadflatpak-2618a19716856d2b107acc0b5b63838e1379ef45.tar.gz
Import ostree's compiler warnings, fix up callers
In ostree I maintain what I consider a "baseline" set of compiler warnings that should *always* be fatal for a modern C project. I noticed while working on a previous patch that a `-Werror=format` warning wasn't fatal. There are a few that are really, really important like `-Werror=missing-prototypes`. I also take some like `-Werror=misleading-indentation` which already caught some bugs. See also https://lwn.net/Articles/678019/
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1ec532e..2576d455 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,6 +53,8 @@ AM_CPPFLAGS = \
-I$(builddir)/lib \
$(NULL)
+AM_CFLAGS = $(WARN_CFLAGS)
+
if WITH_SYSTEM_BWRAP
AM_CPPFLAGS += -DHELPER=\"$(BWRAP)\"
else