summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorwlestes <wlestes>2002-03-06 16:32:59 +0000
committerwlestes <wlestes>2002-03-06 16:32:59 +0000
commitb7285603b2e873ea72884faeb94706ec8fcacb68 (patch)
treed1c3b1a51f0c3d8b03719e22710bbfd2172e08d7 /Makefile.am
parentff14821ad943bdc58699407def42eeed2f06acd1 (diff)
downloadflex-b7285603b2e873ea72884faeb94706ec8fcacb68.tar.gz
remove subdirectories from EXTRA_DIST; add a SUBDIRS macro to handle examples/; clean up the dist-hook target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index b9f0b4b..a9c8079 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,16 +91,16 @@ EXTRA_DIST = \
TODO \
autogen.sh \
flex.skl \
- mkskel.sh \
- tests \
- to.do \
- examples \
- faqs
+ mkskel.sh
+
BUILT_SOURCES = \
skel.c \
parse.c \
-scan.c
+ scan.c
+
+SUBDIRS = \
+ examples
# We have a few dependencies and rules to enumerate. (from the old
# Makefile.in by Vern)
@@ -134,7 +134,3 @@ ChangeLog:
.PHONY: ChangeLog
dist-hook:
- -if test ! "x$(distdir)" = "x" ; then \
- rm -rf `find $(distdir)/ -name CVS` ;\
- fi;
- -cd $(PACKAGE)-$(VERSION) && ./autogen.sh