summaryrefslogtreecommitdiff
path: root/packages/fcl-extra/Makefile
diff options
context:
space:
mode:
authorjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-01-02 15:16:52 +0000
committerjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-01-02 15:16:52 +0000
commita4014b6a863e14daef457b4ac167a0d0e3535e09 (patch)
tree4958840737cb857563bf9615953247b7783c4936 /packages/fcl-extra/Makefile
parentb7e5bee7140c849554134cfcf58d108012153059 (diff)
downloadfpc-a4014b6a863e14daef457b4ac167a0d0e3535e09.tar.gz
* Do not use the BINUTILSPREFIX when compiling fpmake files during a cross-
compile. It seems that CROSSBOOTSTRAP is never set(?) git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@19951 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/fcl-extra/Makefile')
-rw-r--r--packages/fcl-extra/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/packages/fcl-extra/Makefile b/packages/fcl-extra/Makefile
index 18fa623d93..89e909adfe 100644
--- a/packages/fcl-extra/Makefile
+++ b/packages/fcl-extra/Makefile
@@ -1,5 +1,5 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/01/01]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/01/02]
#
default: all
MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mipsel-linux
@@ -1544,12 +1544,16 @@ endif
ifndef CROSSBOOTSTRAP
ifneq ($(BINUTILSPREFIX),)
override FPCOPT+=-XP$(BINUTILSPREFIX)
-override FPCMAKEOPT+=-XP$(BINUTILSPREFIX)
endif
ifneq ($(BINUTILSPREFIX),)
override FPCOPT+=-Xr$(RLINKPATH)
endif
endif
+ifndef CROSSCOMPILE
+ifneq ($(BINUTILSPREFIX),)
+override FPCMAKEOPT+=-XP$(BINUTILSPREFIX)
+endif
+endif
ifdef UNITDIR
override FPCOPT+=$(addprefix -Fu,$(UNITDIR))
endif