summaryrefslogtreecommitdiff
path: root/packages/gtk1/Makefile
diff options
context:
space:
mode:
authormarco <marco@3ad0048d-3df7-0310-abae-a5850022a9f2>2008-10-22 17:32:15 +0000
committermarco <marco@3ad0048d-3df7-0310-abae-a5850022a9f2>2008-10-22 17:32:15 +0000
commit7a0747c767e2d343e590357b0fa065ca83a88500 (patch)
treed93015a49c20f641844c69a2bc51b2b179857071 /packages/gtk1/Makefile
parenta7e984381478aa08d31c38e4bdc0ada51023b933 (diff)
downloadfpc-7a0747c767e2d343e590357b0fa065ca83a88500.tar.gz
* regened makefiles to propagate makefile versions
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@11947 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/gtk1/Makefile')
-rw-r--r--packages/gtk1/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/packages/gtk1/Makefile b/packages/gtk1/Makefile
index 33ba2296f9..f03d40d773 100644
--- a/packages/gtk1/Makefile
+++ b/packages/gtk1/Makefile
@@ -1,5 +1,5 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/06/15]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/10/22]
#
default: all
MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
@@ -115,6 +115,10 @@ FPC:=$(shell $(FPCPROG) -PB)
endif
ifneq ($(findstring Error,$(FPC)),)
override FPC=$(firstword $(strip $(wildcard $(addsuffix /ppc386$(SRCEXEEXT),$(SEARCHPATH)))))
+else
+ifeq ($(strip $(wildcard $(FPC))),)
+FPC:=$(firstword $(FPCPROG))
+endif
endif
else
override FPC=$(firstword $(strip $(wildcard $(addsuffix /ppc386$(SRCEXEEXT),$(SEARCHPATH)))))
@@ -259,7 +263,7 @@ UNITSDIR:=$(wildcard $(FPCDIR)/units/$(OS_TARGET))
endif
PACKAGESDIR:=$(wildcard $(FPCDIR) $(FPCDIR)/packages $(FPCDIR)/packages/base $(FPCDIR)/packages/extra)
override PACKAGE_NAME=gtk1
-override PACKAGE_VERSION=2.0.0
+override PACKAGE_VERSION=2.2.2
ifeq ($(FULL_TARGET),i386-linux)
override TARGET_UNITS+=glib gmodule gdk gtk gdkpixbuf gtkglarea
endif