summaryrefslogtreecommitdiff
path: root/packages/imlib/Makefile.fpc
diff options
context:
space:
mode:
authortom_at_work <tom_at_work@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-09-15 23:41:44 +0000
committertom_at_work <tom_at_work@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-09-15 23:41:44 +0000
commit5e944c6a04675023d3518435cd2cc35aaaabaef5 (patch)
tree50468271d89d84152c05733544152cad7e77faee /packages/imlib/Makefile.fpc
parentd51c0650c1c7629e1178c778b0b03ce0617da51c (diff)
downloadfpc-5e944c6a04675023d3518435cd2cc35aaaabaef5.tar.gz
Pass OPT to compilation of fpmake.
Solves issues with systems that e.g. require special options for compilation of programs (e.g. libc programs to find libc startup code) or the actual build has been compiled with options that are incompatible with default ones. Tested changes by building an i386-linux local build and i386-linux->arm-linux cross-builds git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@22397 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/imlib/Makefile.fpc')
-rw-r--r--packages/imlib/Makefile.fpc2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/imlib/Makefile.fpc b/packages/imlib/Makefile.fpc
index 2425ce77c9..299f64e614 100644
--- a/packages/imlib/Makefile.fpc
+++ b/packages/imlib/Makefile.fpc
@@ -29,7 +29,7 @@ LOCALFPMAKE=.$(PATHSEP)fpmake$(SRCEXEEXT)
.NOTPARALLEL:
fpmake: fpmake.pp
- $(FPCFPMAKE) fpmake.pp $(FPMAKE_SKIP_CONFIG) $(addprefix -Fu,$(COMPILER_FPMAKE_UNITDIR)) $(FPCMAKEOPT)
+ $(FPCFPMAKE) fpmake.pp $(FPMAKE_SKIP_CONFIG) $(addprefix -Fu,$(COMPILER_FPMAKE_UNITDIR)) $(FPCMAKEOPT) $(OPT)
all: fpmake
$(LOCALFPMAKE) compile --localunitdir=../.. --globalunitdir=.. $(FPC_TARGETOPT) $(addprefix -o ,$(FPCOPT)) --compiler=$(FPC) -bu
smart: fpmake